2.5Hp motor shuts off under load

Support forum for our first kit: the PlyFly go-kart
Post Reply
rchappel
Posts: 1
Joined: Mon Sep 28, 2015 2:20 pm

2.5Hp motor shuts off under load

Post by rchappel » Mon Sep 28, 2015 5:12 pm

We have our 2.5HP cart assembled and it looks great. The motor starts easily but will not keep running under any kind of a load. Can anyone help? Some notes:

(1) The motor starts easily
(2) The motor idles forever, both with and without a driver in the cart
(3) On jack stands, the motor idles forever and also will stay running forever with the accelerator depressed
(4) HOWEVER, with a driver in the cart (approx. 80 pounds) and under what should be normal operation, the motor shuts down every time within 10 seconds of the driver depressing the gas pedal. The cart will start and drive normally for ten seconds max and then shut off. Every time.

So, it appears it shuts off whenever any load is placed on it whatsoever. Any ideas? It looks great, but now we want to be able to actually drive it around! Thank you!

Randy

Dave
Posts: 33
Joined: Mon Aug 24, 2015 1:52 pm
Location: Middletown, RI
Contact:

Re: 2.5Hp motor shuts off under load

Post by Dave » Mon Sep 28, 2015 5:39 pm

Hi Randy,
For issues with the 2.5 HP engine, take a look at the topic I posted here: viewtopic.php?f=2&t=203.

My first guess would be trying to play around with the choke a little bit. Leave the choke on at say 1/4 of the way shut (on) and give it a shot. The 2.5 HP engines are pretty de-tuned for emissions certification, so they tend to run pretty lean. In most of their applications it is not an issue, as they run at a constant RPM. They aren't always happy with the opening and closing of the throttle in a go-kart application. Closing the choke a little bit will make it run a little richer, and should clear up your problem!
Dave
Flatworks Engineer

Post Reply